Wikia

coLinux

DebianRootFsImages

238pages on
this wiki
Talk0

2.6.x-based Edit

Bringing Things Up to Date Edit

This pertains to Debian-20040605-mit.ext3.1610mb.bz2

The root filesystem images are already somewhat old. I found it useful to take the following steps as soon as I had a network connection working:

In /etc/apt/sources.list, comment out the "non-us" repository. It is obsolete.

Some people might be getting the "Dynamic MMap out of room" error while trying to apt-get. To fix it, open the apt config file at /etc/apt/apt.conf.d/70debconf, and add this line:

APT::Cache-limit "8388608";

Now you can update normally.

apt-get update

apt-get dist-upgrade

It might be necessary to repeat these two instructions a few times.

I got an error regarding e2fsprogs. To remedy the error, I simply did this:

DON'T RUN THIS COMMAND YET!! READ BELOW!! DON'T RUN THIS COMMAND YET!! READ BELOW!!


apt-get remove e2fsprogs

(I had to type in something, like "Yes, I really want to do this! Do as I say!" I replied "yes" when asked if I should upgrade packages along the way.

This update comes with a real risk!!! When I did it the first time, the command "update-rc.d" was removed from the system, propably during the deinstallation of the package "sysv-rc". This command is essantial for any further package installation, including the removed package "sysv-rc". Any package installation will fail after this binary has been deleted! I had to install the image again and start from the beginning! Therefore do make a copy of the system-image before trying to remove the package "e2fsprogs"!

Before removing the package "e2fsprogs" I installed (during my second try) the package "sysv-rc":

apt-get install sysv-rc

After doing this the removal of the package "e2fsprogs" was no problem.

apt-get install e2fsprogs

apt-get dist-upgrade

Install dhcp client:

apt-get install pump

apt-get install gnupg

apt-get update


Note: mirrorselect may come in handy.


BiafraRepublic's instructions for upgrading the default Debian (Woody) image (Debian-3.0r2.ext3-mit-backports.1gb.bz2):

1.) If any exist, remove/comment out the non-us entries from '/etc/apt/sources.list', as well as the backports.org entry for kernel-image-2.6.6-i386 (which returns a 404 error).

(If desired, add a line to a local Debian volatile repository (perfect you wish to add frequently updated items such as antivirus software. spam filters, etc.) Just add the following line to your sources.list file...)
deb http://ftp.uk.debian.org/debian-volatile/ stable/volatile main

2.) Update the package lists

apt-get update

3.) Upgrade your distribution to the latest 'stable' version (Sarge)

apt-get dist-upgrade

4.) Repeat steps 2 and 3 as necessary

5.) The above steps also install the package manager aptitude onto your system, so if you wish to add anything from the command line, type the following to load it up

aptitude

Around Wikia's network

Random Wiki